2003 Tahoe AC Blend Door Actuator Test - Chevrolet Forum - Chevy Enthusiasts Forums

Tahoe & Suburban The power, space, and brutal towing ability make the Tahoe and its longer sibling, the Suburban, arguably the best full size SUV's on the market today.

2013 Chevrolet Suburban
Platform: GMT 400, 800, 900
Sponsored by:
Sponsored by:

2003 Tahoe AC Blend Door Actuator Test

Reply

 
 
 
Old July 11th, 2018, 2:35 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: Jul 2018
Posts: 1
Default 2003 Tahoe AC Blend Door Actuator Test

Quick question, I have searched, but am having a tough time finding what I need.

The drivers side was continually blowing hot air. I pulled out the lower blend door actuator for the drivers side vents so I could watch it, and adjusted the temp control from hot to cold and the actuator didn't move (rotate). So I figure it was a bad actuator.

Before picking up a new one I pulled the top cover and jumped the motor and everything worked as it should (both ways, right and left). All gears looked good.

I tested the electrical plug for actuator and the first wire has power, and the rest have no power. When I adjust the temp control hot to cold, the first wire has power but all the rest still have no power. Shouldn't I be getting power to one of the other wires to activate the actuator one way or the other when adjusting the temp control?

Not sure if it is a bad temp control or a bad blend door actuator.

Thanks for your help.
Bill
willyg1997 is offline  
Reply With Quote
Reply
 
 
 


Thread Tools
Search this Thread
Sponsors
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: