2007 Suburban 1500 starts idle when im driving... - Chevrolet Forum - Chevy Enthusiasts Forums
Sponsored by:

2007 Suburban 1500 starts idle when im driving...


Mattias Skroder's Avatar
CF Beginner

Join Date: Jan 2018
Posts: 5

June 12th, 2018, 7:34 AM   #1  
2007 Suburban 1500 starts idle when im driving...

Hi. First of all i want to say that im from Sweden so my English maybe is'nt the best.

i have a problem that i cant figure out what it is. Sometime my burb can go down to idle rpm when i drive down the highway at 60-70mph. Or when i let go off the throttle before a roundabout. I had this problem before and suddenly it disappeared for 3-4 month. And now its back. Any ideas what it might be?

 
cwkerr007's Avatar
CF Beginner

Join Date: Jun 2018
Posts: 4

June 13th, 2018, 10:07 AM   #2  
your electronic fuel pedal is bad or has a bad connection

 
Mattias Skroder's Avatar
CF Beginner

Join Date: Jan 2018
Posts: 5

June 13th, 2018, 12:20 PM   #3  
Posted By: cwkerr007 your electronic fuel pedal is bad or has a bad connection
Is it the gas pedal you mean or something on the intake?

i dont know much about these things

 
cwkerr007's Avatar
CF Beginner

Join Date: Jun 2018
Posts: 4

June 13th, 2018, 12:24 PM   #4  
the pedal itself has a variable switch on it may just be connection ive replaced many of them

 
Mattias Skroder's Avatar
CF Beginner

Join Date: Jan 2018
Posts: 5

June 13th, 2018, 12:35 PM   #5  
Posted By: cwkerr007 the pedal itself has a variable switch on it may just be connection ive replaced many of them
okey thanks i will look in to that

 
Search this Thread
Sponsors
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: