Notices
Tahoe & Suburban The power, space, and brutal towing ability make the Tahoe and its longer sibling, the Suburban, arguably the best full size SUV's on the market today.

2013 Chevrolet Suburban
Platform: GMT 400, 800, 900

2015 Tahoe LTZ Rough engine after braking

Old December 30th, 2015, 12:45 AM
  #1  
CF Beginner
Thread Starter
 
Join Date: Dec 2015
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Cool 2015 Tahoe LTZ Rough engine after braking

So, im having an issue where i would come to a stop and im on the brakes. Roughly about 10 Seconds later... engine starts to get a bit rough. I began to think its something to do with the brake booster or a vacuum leak since it only happens after braking. Took it to dealer and they said it was normal, but it didnt used to do that before. Any idea of what else it could be.?

Last edited by Dylan Kawano; December 30th, 2015 at 2:30 AM.
Dylan Kawano is offline  
Old December 30th, 2015, 11:11 AM
  #2  
Administrator
 
in2pro's Avatar
 
Join Date: Apr 2008
Location: Austin, Texas
Posts: 7,526
Likes: 0
Received 0 Likes on 0 Posts
Default

Welcome to the forum,
I too would suspect vacuum leak or poor recovery....
in2pro is offline  
Old December 30th, 2015, 12:47 PM
  #3  
CF Senior Member
 
Join Date: Jan 2015
Posts: 320
Likes: 0
Received 0 Likes on 0 Posts
Default

sounds like booster valve is not shutting properly
Scotiapilot is offline  
Old December 30th, 2015, 8:01 PM
  #4  
CF Beginner
Thread Starter
 
Join Date: Dec 2015
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Didn't think about that one, but I will try and see if I can take a look at it and see whats up. If I can manage to get a smoke tester to check to see if there is any small leaks somewhere because, apparently in an a compartment on the drivers side of the engine bay behind the headlight, there is rat poop... so it could be possible that it got chewed into a little bit which is causing the leak.
Dylan Kawano is offline  
Old January 1st, 2016, 12:10 PM
  #5  
CF Veteran
 
Join Date: Feb 2012
Location: nebraska
Posts: 1,433
Likes: 0
Received 0 Likes on 0 Posts
Default

they're having issues with the engine mounts, some need shimmed or played around with but the complaint is usually just rough idle has nothing to do with the brakes

Last edited by cleveland63b; January 2nd, 2016 at 11:23 AM.
cleveland63b is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: