Air bag light - Chevrolet Forum - Chevy Enthusiasts Forums

Tahoe & Suburban The power, space, and brutal towing ability make the Tahoe and its longer sibling, the Suburban, arguably the best full size SUV's on the market today.

2013 Chevrolet Suburban
Platform: GMT 400, 800, 900

Air bag light

Reply

 
 
 
Old August 7th, 2018, 5:06 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: Aug 2016
Posts: 5
Default Air bag light

went to have my suburban inspected and the air bag light is on. My mechanic changed both front sensors and the code immediately comes back. He said the current is fluctuating to the sensors causing the issue. Said to take it to the dealership to fix. The dealership said it was the air bag sensors and replacing them would fix it. I told them what my mechanic said however they still said itís the sensors. they replaced them and the light still comes on. I reiterated the wire current issue but they say itís a calibration issue with the new sensors. They have had my car for 2 days and still not fixed. Today they were supposedly on the phone with GM tech support trying to figure it out. I am beyond frustrated now bc I am just racking up diagnostic charges and nothing is being accomplished. They also tried telling me I needed all of this other work done to pass inspection that my mechanic says doesnít need to take place. Anyone have any ideas what could be going on with the air bag system???
EHOIV is offline  
Reply With Quote
Old August 8th, 2018, 12:59 AM
  #2  
CF Monarch
 
tech2's Avatar
 
Join Date: Mar 2011
Posts: 6,130
Default

impossible to say without codes
tech2 is offline  
Reply With Quote
Old August 8th, 2018, 8:49 PM
  #3  
CF Beginner
Thread Starter
 
Join Date: Aug 2016
Posts: 5
Default

The codes that are being thrown are B0083 and B0084. The said today it was the control module and they replaced that but the codes still showed up. They have checked all wiring from the two front sensors to the module and no issues with the wiring. This afternoon they told me that there are actually 4 sensors in the front so they are going to check the other two tomorrow AM. Anyone ever experienced anything like this. Itís starting to get a little ridiculous!!
EHOIV is offline  
Reply With Quote
Old August 8th, 2018, 11:08 PM
  #4  
CF Monarch
 
tech2's Avatar
 
Join Date: Mar 2011
Posts: 6,130
Default

model year, engine
tech2 is offline  
Reply With Quote
Old August 9th, 2018, 4:48 AM
  #5  
CF Beginner
Thread Starter
 
Join Date: Aug 2016
Posts: 5
Default

2008 1500
EHOIV is offline  
Reply With Quote
Old August 9th, 2018, 10:57 PM
  #6  
CF Monarch
 
tech2's Avatar
 
Join Date: Mar 2011
Posts: 6,130
Default

the codes should have suffixes ie 00 or OF. this describes the type of fault.
b0083 is set for the front end sensor...00 would mean the fault is short to grd, voltage or open circuit.

the fault can only be in the sensor, the module or the wiring that connects the two. since swapping the sensor didn't fix it; the wires should be checked...for open and shorts. if the wiring is ok and the sensor is ok...by default...replace the module. there is no way to test a module so you test everything else first and if it all checks out replace the module.
tech2 is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: