Tahoe hard to start when cold - Chevrolet Forum - Chevy Enthusiasts Forums

Tahoe & Suburban The power, space, and brutal towing ability make the Tahoe and its longer sibling, the Suburban, arguably the best full size SUV's on the market today.

2013 Chevrolet Suburban
Platform: GMT 400, 800, 900
Sponsored by:
Sponsored by:

Tahoe hard to start when cold

Reply

 
 
 
Old January 12th, 2018, 5:54 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: Jan 2018
Posts: 6
Default Tahoe hard to start when cold

It started to get harder and harder to start in cold temps. But now it won't start at all. It had a complete tune up 3 yrs ago, new fuel pump & filter 1 yr ago, It will turn over but sounds like it either isn't getting a spark or fuel. Just prior to this it would turn over several times before finally starting it seem s once it was warmed up I had no problem. But I have only been using the car every 4 days or so and the average temp are mid to low 30's
kelly brown is offline  
Reply With Quote
Old January 12th, 2018, 9:33 PM
  #2  
CF Monarch
 
tech2's Avatar
 
Join Date: Mar 2011
Posts: 6,031
Default

if it has a long crank before it starts...cycle the key to run for 2 seconds repeatedly. do this 5x and then try to start the engine. if its starts up normally the fuel system is leaking down. cycling the key primes the fuel rail.
tech2 is offline  
Reply With Quote
Old January 13th, 2018, 11:08 AM
  #3  
CF Beginner
Thread Starter
 
Join Date: Jan 2018
Posts: 6
Default

Hey Tec 2 thank you for your response, I will try that, I was assuming that it was fuel or electrical. I did put a new Delphi fuel pump and in line filter in about 8 months ago.
kelly brown is offline  
Reply With Quote
Old January 15th, 2018, 10:12 AM
  #4  
CF Beginner
Thread Starter
 
Join Date: Jan 2018
Posts: 6
Default hard to start

Hey Tec 2
I tried cycling the ignition to build fuel pressure and it still won't start.After reading through some more threads I'm thinking it could be the
ECM since this seems to be associated with cold weather I'm gonna try warming the ECM and then try starting again. Thanks for your input
kelly brown is offline  
Reply With Quote
Old January 16th, 2018, 5:15 PM
  #5  
CF Beginner
Thread Starter
 
Join Date: Jan 2018
Posts: 6
Default

I did heat the ECM up with a hair dryer and it acted like it did try to fire. Before it seemed like it did nothing. I I am assuming it is the ECM. I will pick up another and will post the results. But so far that is what it looks like
kelly brown is offline  
Reply With Quote
Reply
 
 
 


Thread Tools
Search this Thread
Sponsors
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: