Go Back  Chevrolet Forum - Chevy Enthusiasts Forums > Past Chevy Truck, SUV & Vans > TrailBlazer
Reload this Page >

2004 Trailblazer electrical motor surge while driving

Notices
TrailBlazer 2002-2009
The TrailBlazer, originally introduced as an upscale Blazer, was produced from 2002 to 2008 with a powerful I6 engine and with a monster V8 offered in the Trailblazer SS
Platform: GMT 305, 360, & 370.

2004 Trailblazer electrical motor surge while driving

Old July 2nd, 2019, 8:04 AM
  #1  
CF Beginner
Thread Starter
 
Join Date: Jul 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default 2004 Trailblazer electrical motor surge while driving

So this is an intermittent issue and I cant seem to find any other cases. While running at high speed on the interstate, when I am not accelerating, I hear an electrical motor engaging and surging. As soon as I accelerate, then surging stops. That last time this happened, I was 45 miles from home. I pulled off the interstate and the noise ceased. It didn't do it again until I exited at home. It has done this before on that same exit which is about 1/4 mile long and has a speed limit of 45. As I slow down, the motor stops. My awd was fixed by a new module but now my 4wd lo is not working. I'm wondering if this is an out of control actuator? Any other ideas or help appreciated.
Tclaffy is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: