Transmission problems - Chevrolet Forum - Chevy Enthusiasts Forums

Transmission problems


doyjt's Avatar
CF Beginner

Join Date: Feb 2018
Posts: 4

February 10th, 2018, 6:18 PM   #1  
Transmission problems

I purchased a 2004 trailblazer was not shifting right and service 4wd light came on when I tried to put in 4wd, so pulled pan on transmission changed 2 shift solenoids new filter put back on road drove a couple days then would not shift into 3rd gear, bought a tranny from an 06 tb put it in and got no gears at all was not pumping any fluid but the 4wd service light went out and it would go into 4 hi and 4 low, so I pulled that tranny out, changed all the solenoids in original tranny put back in still will not shift into 3rd and service 4wd light is back on what am I missing

 
kevinkpk's Avatar
CF Addict

Join Date: Jul 2011
Posts: 3,909

February 10th, 2018, 6:31 PM   #2  
Are you getting any codes? How many miles?

 
doyjt's Avatar
CF Beginner

Join Date: Feb 2018
Posts: 4

February 10th, 2018, 6:37 PM   #3  
No codes 167,00 miles

 
doyjt's Avatar
CF Beginner

Join Date: Feb 2018
Posts: 4

February 11th, 2018, 2:57 PM   #4  
What is the difference between the 04 and 06 that will not let it shift

 
kevinkpk's Avatar
CF Addict

Join Date: Jul 2011
Posts: 3,909

February 11th, 2018, 5:15 PM   #5  
Have you tried putting the shift lever in 1, then 2, then see if it will shift manually into 3, 4?

 
doyjt's Avatar
CF Beginner

Join Date: Feb 2018
Posts: 4

February 11th, 2018, 6:05 PM   #6  
Tranny from 06 got nothing at 04 tranny shifts ok 1 and 2 drops out in 3 not slipping just will not go into 3 rd

 
Search this Thread
Sponsors
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: