2003 Venture rough idle - Chevrolet Forum - Chevy Enthusiasts Forums

Venture 1997-2005
This minivan from Chevy offers a sporty look as well as all of the modern additons of the minivan market.
Platform: U-Body

2003 Venture rough idle

Reply

 
 
 
Old April 17th, 2018, 12:33 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: Apr 2018
Location: Ontario
Posts: 20
Unhappy 2003 Venture rough idle

Hello all. I hope I can get a few answers before pulling my van into the shop. I love venture vans and have owned 3 of them. This one was bought for roughly 300 bucks and safety for about 100 bucks more. So far It has gotten a new upper power steering hose and 3 new fuel lines. So it was just in the shop. That was about a month ago from this post. Everything was running fine until today I got in the van to go to work. It all ran great into town and going to the next town. On the way back the engine light started to flash and is really ran rough when idling. Turn it off and back on again and the engine light would stay on and it would have a bit more power. This changed when turning it on and off some of the time. So, I bought it home and started to do research.

I have been here a few times reading the posts and have been helped before just by being a guest. I figured this time I would post and see what would happen. I don't have any codes at all for this cause it literally just happened. From what I have read it could be plugs or wires or coils...I don't know. I need a bit of help.
bigguychevy is offline  
Reply With Quote
Old April 18th, 2018, 12:09 PM
  #2  
CF Beginner
Thread Starter
 
Join Date: Apr 2018
Location: Ontario
Posts: 20
Default

Ok, so I had it into the shop and they put a tester on it. They said that cylinder two is misfiring. Is this something I can get at with limited tools and change the plug and the wire. ?? Like is it back by the firewall or upfront. ??
bigguychevy is offline  
Reply With Quote
Old April 18th, 2018, 7:04 PM
  #3  
CF Beginner
Thread Starter
 
Join Date: Apr 2018
Location: Ontario
Posts: 20
Default

Can anyone point me in the direction of which plug I should change. maybe. ??

PO302 was the code.

Last edited by bigguychevy; April 18th, 2018 at 8:26 PM. Reason: adding edit
bigguychevy is offline  
Reply With Quote
Old April 19th, 2018, 6:46 AM
  #4  
CF Beginner
Thread Starter
 
Join Date: Apr 2018
Location: Ontario
Posts: 20
Default

So I figured out that cylinder 2 is at the front of the van. Sounds easy enough.

Last edited by bigguychevy; April 24th, 2018 at 6:51 PM.
bigguychevy is offline  
Reply With Quote
Old April 24th, 2018, 6:52 PM
  #5  
CF Beginner
Thread Starter
 
Join Date: Apr 2018
Location: Ontario
Posts: 20
Default

Now I find out that the van is runnin great. I had it by a shop and they cleared the code and since all this dry weather it has ran great. Seems it must be plugs, wires or distributor cap. (I think)
bigguychevy is offline  
Reply With Quote
Reply
 
 
 


Thread Tools
Search this Thread
Sponsors
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: