'06 Impala rear defogger not working - Chevrolet Forum - Chevy Enthusiasts Forums

'06 Impala rear defogger not working


  Reply  
Join Date: Sep 2008
Posts: 2

September 26th, 2008, 9:44 AM   #1  
'06 Impala rear defogger not working

My rear defogger quit working in my '06 Impala. The owners manual only references the rear defogger relay in the fuse box under the hood. I checked it and verified it was good. When you push the button on the console air controls the light comes on like the rear defogger should be working but nothing else happens. Are there more fuses or relays I should be looking for?

 
shawnvw's Avatar
Super Moderator
Professional Mechanic

Join Date: Jan 2008
Posts: 2,571

September 26th, 2008, 2:07 PM   #2  
RE: '06 Impala rear defogger not working

check to make sure the tab isn't broken off the window, then use a test light hooked up to both tabs while the defrost is on and see if it lights up.

 
rbarrios's Avatar
CF Senior Member

Join Date: Feb 2007
Posts: 339

September 26th, 2008, 5:48 PM   #3  
RE: '06 Impala rear defogger not working

sounds like someone prob wiped a little hard back there and broke a tab

 
Join Date: Sep 2008
Posts: 2

September 28th, 2008, 12:13 PM   #4  
RE: '06 Impala rear defogger not working

After looking at it closerit does appear that the tab has come unglued from the window.

Thanks for the suggestions.

Is there a special adhesive I need to re-glue this back to the grid????? or can I use anything like a super glue?

 
rbarrios's Avatar
CF Senior Member

Join Date: Feb 2007
Posts: 339

September 29th, 2008, 6:06 PM   #5  
RE: '06 Impala rear defogger not working

you need to make sure that the wires remain connected- even those on the glass. if theres a break in the wires- it wont work.
auto parts have kits to repair the lines.
But youll know which one doesnt work cause the rest of the glass clears up, except the non workin one-
but sounds like your trouble is right at the connector area

 
shawnvw's Avatar
Super Moderator
Professional Mechanic

Join Date: Jan 2008
Posts: 2,571

September 29th, 2008, 6:29 PM   #6  
RE: '06 Impala rear defogger not working

Take it to an auto glass place and see if they will even attempt to repair it. A lot of places will not touch it because the heat fromthe soldering gun can cause the glass to shatter. And it needs to be solder to have a reliable fix

 
Tags
Search this Thread
Sponsors
Related Topics