Service engine light on and off - Chevrolet Forum - Chevy Enthusiasts Forums

Service engine light on and off


Jcm59's Avatar
CF Beginner

Join Date: Jan 2018
Posts: 4

January 12th, 2018, 5:51 PM   #1  
Service engine light on and off

We have a 2006 Silverado 1500 extended cab. The service engine light has been coming on and going off for sever years. We first took it to the dealer and they said nothing wrong with it and it was probably a faulty sensor and would have to replace the instrument panel. I could not afford that it seems to come and go off when ever we hit a bump in the road. We live on a dirt road and it is a little rough but it can just be a bump going down the street. We have alway been lucky in the sense that it has been off when it ever we have to get it smoged. But lately it has been staying on for long periods and it is due to get smoged next month if it is on it wonít pass even if there is nothing wrong. Not sure how to fix this.

 
tech2's Avatar
CF Monarch

Join Date: Mar 2011
Posts: 5,505

January 12th, 2018, 10:44 PM   #2  
get the code read and post the code here

 
Jcm59's Avatar
CF Beginner

Join Date: Jan 2018
Posts: 4

January 13th, 2018, 1:04 AM   #3  
No codes

there are no codes thatís the problem if there was I would no what to fix

 
tech2's Avatar
CF Monarch

Join Date: Mar 2011
Posts: 5,505

January 13th, 2018, 6:31 PM   #4  
hard to say over the internet...my best guess would be a cluster problem. if you could get a cheap one from pnp to swap in. if that fixes it have it sent away for programming.

 
Jcm59's Avatar
CF Beginner

Join Date: Jan 2018
Posts: 4

January 13th, 2018, 6:56 PM   #5  
What is a cluster

 
oldchevy's Avatar
CF Addict

Join Date: Apr 2012
Posts: 2,800
Miami, FL.

January 14th, 2018, 2:19 AM   #6  
Instrument cluster or as you called it instrument panel.

 
tech2's Avatar
CF Monarch

Join Date: Mar 2011
Posts: 5,505

January 14th, 2018, 2:19 AM   #7  
instrument panel cluster...the mil light that is coming on...its part of the cluster.

 
Jcm59's Avatar
CF Beginner

Join Date: Jan 2018
Posts: 4

January 14th, 2018, 9:30 AM   #8  
Than you I will look into replacing it hopefully not to difficult. Itís due for a smog and the light was off yesterday hopefully it stays off tomorrow so we can get it smoged. Is there a part inside the panel that is responsible for like a loose bulb or bad connection that I can check

 
tech2's Avatar
CF Monarch

Join Date: Mar 2011
Posts: 5,505

January 14th, 2018, 2:32 PM   #9  
its a led soldered to a circuit board. youtube it.

to pass the emissions test...the mil must come on at key on as part of the bulb check function. Its should turn off when started and all of the I/M monitors must run and pass. If any are incomplete...no pass.

 
Search this Thread
Sponsors
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: