Notices
Impala While undergoing many facelifts in its history, the Impala has proved itself to both civilians and police forces as one of the most capable 4-door cars GM has ever offered. Currently moving towards its 10th generation the Impala is one of the longest lasting and popular models.

2014 Chevrolet Impala
Includes: Bel-air
Platform: B-body & W-body

turn signals work \ dont work

Old September 1st, 2010, 2:01 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: Sep 2010
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Cool turn signals work \ dont work

I have a quirky problems on a 01 Impala ls. 3.8l-auto. sometimes the turn signals do not function at all, other times all is normal. You can drive off and check them before departing then... the next time you go to use them ...nothing. Park, then return... they work fine. Anyone else had them problem?

thx,

Dave
uncledave11 is offline  
Old September 4th, 2010, 7:27 AM
  #2  
CF Beginner
 
Join Date: Mar 2010
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default common

it is a common problem with 2000-05 not sure what causes it but if you will hit the hazard button when the won't work, presto they start working again
rick41018 is offline  
Old September 6th, 2010, 12:07 PM
  #3  
CF Beginner
Thread Starter
 
Join Date: Sep 2010
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default no turn signals-mystery solved!

Yup, Engineers do, do tthings differently sometimes. Like wiring the hot through the hazard switch. you were correct about "stabbing" the button (hazzard switch) to get the signals going again. That worked. It acted up again for I did 1 better to correct the problem: CRC makes a great safe product called "Lectro-motive" It's a spray cleaner for electrical contacts, switches, motor commutors, armitures, etc. Does not react with plastics, cause shorts or other undesireable effects. I strayed inside the hazzard switch from the side while "exercising" it's operation. Then immediately did the same blowing it out with compressed air. Repeated the process again and now no more failures. My guess is that a cleaned a contact in the switch that was a "common power buss feed to both circuits. It's well worth a try to anyone out there that has the same problem. Not using the hazzard switch from day to day evidently allows dust, dirt or other gook to block the contact point inside the switch that should be "12v hot" all the time. Hope that helps!

Dave
uncledave11 is offline  
Old September 8th, 2010, 7:06 PM
  #4  
CF Beginner
 
Join Date: Feb 2010
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
Default

replace the hazard switch, it contains flasher relay
77k10 is offline  
Old September 9th, 2010, 10:10 AM
  #5  
CF Beginner
Thread Starter
 
Join Date: Sep 2010
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

That may be true, but i have not had one "failure" since cleaning the contacts and exercising the swithch. having rebuilt several european switches w\ 95%+ success in the last 20 years, I do believe that replacing a 9 year old assembly with a new "made in china" junk switch would be unwise. Todays "multi vendor", lowball outsouce products, mean wasted dollars on cut cost designs not made to last. As long as the internal relay contacts & solenoid are still good, why take a chance on a "new" part that isn't a nearly well made. Think about that the new time you purchase an electrical (or "oem" quality-ha!) or other part in the future! Good luck & thanks for the reply.

Dave
uncledave11 is offline  
Old September 10th, 2010, 7:12 AM
  #6  
CF Beginner
 
Join Date: Feb 2010
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
Default

Kinda hard to say that the new switch would be less quality than the original considering the fact that this is a very common problem in the impalas. And whose to say the original was actually made in america. But none the less the new ones are pretty dam expensive for what they are so if you can fix the one you got then thats way cheaper than buying a new one!
77k10 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ky1duck
Impala
6
February 9th, 2015 8:34 AM
Lymsleia
Cavalier
2
August 14th, 2011 10:48 PM
timberland73
Impala
5
December 16th, 2009 11:04 PM
Manor_Mullet
S-10 & Blazer
2
April 28th, 2008 2:13 PM


Thread Tools
Search this Thread
Quick Reply: turn signals work \ dont work


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: