Notices
S-10 & Blazer 1982-2005
The S-10 and Blazer was arguably the most versatile and accessorizable mid-size truck and SUV on the market.
Platform: S/T-series & GMT 330

2002 Chevy S-10 running rough

Old June 19th, 2012, 6:54 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: Jun 2012
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default 2002 Chevy S-10 running rough

I replaced the fuel pump in my truck about 2 months ago, and i guess i didn't get a good seal on the top with the o-ring. My check engine light has been on ever since with the code P0440, but today it just started running rough, and while i was on the freeway the check engine light started blinking.. I got the truck to limp home, having to keep it above 2000rpm at idle to keep it from dying... when i got home i read the codes, came up with 4: P302, P0440, P0302, P0440...any suggestions on this?
Drew B is offline  
Old June 20th, 2012, 6:04 AM
  #2  
CF Addict
 
oldchevy's Avatar
 
Join Date: Apr 2012
Location: Miami, FL.
Posts: 3,611
Likes: 0
Received 3 Likes on 3 Posts
Default

Cylinder #2 misfiring. Check everything associated with #2 cylinder. Spark plug, wires, dist cap, injector etc. It would also be a good idea to fix the seal at the top of the tank.
oldchevy is offline  
Old June 21st, 2012, 12:16 PM
  #3  
CF Beginner
Thread Starter
 
Join Date: Jun 2012
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

yeah, i know, i really do need to fix that seal on the tank. do you think that with it not having a good seal, and the pressure being messed up that it could have affected the injectors?
Drew B is offline  
Old June 21st, 2012, 7:29 PM
  #4  
CF Addict
 
oldchevy's Avatar
 
Join Date: Apr 2012
Location: Miami, FL.
Posts: 3,611
Likes: 0
Received 3 Likes on 3 Posts
Default

If the pressure is too low then it definitely will affect the injectors and the engine. I don't think the seal would because I have left the cap loose by accident and the truck ran great. It did throw a code.
oldchevy is offline  
Old July 10th, 2012, 6:17 PM
  #5  
CF Beginner
Thread Starter
 
Join Date: Jun 2012
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

I just wanted to write back and say thanks for the advice. I ended up changing out all my spark plugs and wires, then i was throwing code for multiple cylinder misfire. So then i decided to change my distributor cap, and that fixed the problem. Thanks again!
Drew B is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Scott6712
New Member Welcome Area
3
July 21st, 2015 2:35 AM
Mechanicman
S-10 & Blazer
0
April 25th, 2013 10:49 PM
circlenbar
TrailBlazer
1
December 11th, 2012 6:42 AM
stanman
General Tech
3
October 6th, 2012 6:50 PM
macmommy
Tahoe & Suburban
8
October 1st, 2010 10:04 PM


Thread Tools
Search this Thread
Quick Reply: 2002 Chevy S-10 running rough


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: