Go Back  Chevrolet Forum - Chevy Enthusiasts Forums > Past Chevrolet Cars > Cavalier
Reload this Page >

95 Z24 2.3L Sometimes starts, other times just cranks, HELP!!!!

Notices
Cavalier Starting in the 1980s. the Cavalier made a name for itself by offering an affordable 2 and 4 door compact.
Platform: J-body

95 Z24 2.3L Sometimes starts, other times just cranks, HELP!!!!

Old February 28th, 2012, 12:17 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: Feb 2012
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default 95 Z24 2.3L Sometimes starts, other times just cranks, HELP!!!!

I was given this car from my dad and It is a 95 Cavalier 2 door 5speed Z24 with 2.3L motor.

Problem is that it sometimes starts, otherwise it just cranks over and over and over. The only thing I had noticed is that the oil light would sometimes come on, it didnt effect the drivablity or performance of the car. So thats why I put a new sensor in. You can hear the fuel pump run for around 5 seconds when you put the ignition to run, and from the underhood fuse/relay box you can hear a click sound when you put the key in run position.

I am Stumped! Why will the car run great and start sometimes, other times it will not start no matter what. I need reliablity from this car. Any suggestions???

**EDIT** CAR DOES NOT GET SPARK, PLUGS ARE DRY


There are no check engine lights

NEW PARTS PUT ON -
I have replaced the fuel pump with an AC DELCO one.
New Fuel filter
New Fuel pump relay
New Oil pressure sensor

Last edited by ShaunLB84; February 28th, 2012 at 12:51 PM.
ShaunLB84 is offline  
Old February 28th, 2012, 8:21 PM
  #2  
CF Beginner
Thread Starter
 
Join Date: Feb 2012
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default

Really? No ideas???
ShaunLB84 is offline  
Old February 28th, 2012, 9:13 PM
  #3  
CF Veteran
 
Join Date: Mar 2011
Posts: 1,709
Likes: 0
Received 0 Likes on 0 Posts
Default

Welcome to the forum. So, what do you do in those occasions when it doesn't start? Do you own a meter (digital multimeter or analog VOM, makes no difference) and know how to use it?
EinST is offline  
Old February 29th, 2012, 9:08 AM
  #4  
CF Beginner
Thread Starter
 
Join Date: Feb 2012
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default

Thank you for the welcome. Yes I do own a multimeter and can use it

And I have just been driving a different vehicle, I would hate for it to start up at home and go to the store and have to pay for a tow truck to take me home
ShaunLB84 is offline  
Old February 29th, 2012, 11:56 AM
  #5  
CF Veteran
 
Join Date: Mar 2011
Posts: 1,709
Likes: 0
Received 0 Likes on 0 Posts
Default

Okay, then, you want to pay close attention to what happens in the I/P cluster when you first turn the key on. The gauges and indicators will go through the bulb test and then settle down. Is the Check Engine Light (CEL) on afterward? What does the THEFT SYSTEM indicator do? I suspect one or both of them may do something different when you can start the engine vs. when you can't.

When you can't start the engine (it cranks without catching), leave the key on and then check the voltage on various fuses in the I/P fuse block. Preferably ground the black probe on a good grounding point and then insert the red probe (mine's been worked to a sharp point) into the holes on the fuses. Pay close attention to voltage levels on anything labeled PCM or ERLS. They should be close to or above 12V.
EinST is offline  
Old February 29th, 2012, 12:55 PM
  #6  
CF Beginner
Thread Starter
 
Join Date: Feb 2012
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default

I replaced the ignition switch and it fires right up. I have read the recall on them and figured the symptoms matched mine.
ShaunLB84 is offline  
Old February 29th, 2012, 1:32 PM
  #7  
CF Beginner
Thread Starter
 
Join Date: Feb 2012
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default

Now the car doesn't start after letting it sit since I changed it. After the bulb test the check engine light, battery light and oil can light are all staying lit.


The weird thing is I can't get a 12v reading under the hood unless I ground it to the battery, inside the car I grounded to seat rail and I could get 12v readings from the in dash fuse box.

All fuses check out to around 12v, battery checks out at 12.48.

Crankshaft position sensor connection is at 777Ohms which the manual says it should be 500-900 Ohms so that checks out fine.

***EDIT*** Disconnected the battery while I Changed all the spark plugs, and changed the oil since autozone was having a sale. The car Started every time since that, let engine get to warm...shut it off...turned it back on...shut off x4. And it has started everytime.

I am going to let the engine get cold and try it again.

**EDIT** Car was cold and started right up again.

Anything else I could check in case the problem is not solved? This is very weird!!!

Last edited by ShaunLB84; February 29th, 2012 at 4:08 PM.
ShaunLB84 is offline  
Old February 29th, 2012, 6:08 PM
  #8  
CF Veteran
 
Join Date: Mar 2011
Posts: 1,709
Likes: 0
Received 0 Likes on 0 Posts
Default

I was trying to see if there's something going on with the ignition switch or Passlock sensor but it doesn't look like it. Without seeing it for myself, I can't tell if you have a ignition problem (lack of spark) or fuel problem. I hate to suggest throwing more parts at it.
EinST is offline  
Old February 29th, 2012, 11:57 PM
  #9  
CF Beginner
Thread Starter
 
Join Date: Feb 2012
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default

I don't know if this means anything but my Dad brought home his snap on diagnostics scan tool and I couldn't get communication from my OBD port to the scanner. When you plug the scan tool into the OBD port a light comes on the scan tool saying it is charging the scan tool(its like a mini computer) so the OBD port has power. And my cigarette lighter is working, I have heard that those two are connected somehow.

Car has still started up everytime, since I unplugged the battery and changed the sparkplugs and oil.

Last edited by ShaunLB84; March 1st, 2012 at 12:03 AM.
ShaunLB84 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Silverado22
Silverado & Fullsize Pick-ups
3
April 27th, 2015 12:18 PM
Jared Phillips
Silverado & Fullsize Pick-ups
1
April 12th, 2015 12:24 PM
WUG
General Tech
0
February 23rd, 2015 8:23 PM
02suburban
Tahoe & Suburban
1
January 19th, 2015 12:33 PM
tlspirit
Venture
0
October 17th, 2010 9:17 AM


Thread Tools
Search this Thread
Quick Reply: 95 Z24 2.3L Sometimes starts, other times just cranks, HELP!!!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: