Notices
General Tech Good at troubleshooting? Have a non-specific issue? Discuss general tech topics here. IF YOUR QUESTION IS SPECIFIC TO A CERTAIN MODEL, IT DOES NOT GO IN THIS SECTION.

(2006 EQUINOX) 2 cooling fan ALWAYS ON !

Old April 7th, 2008, 6:38 AM
  #1  
CF Beginner
Thread Starter
 
Join Date: Apr 2008
Posts: 1
Default (2006 EQUINOX) 2 cooling fan ALWAYS ON !

Hello I rebuilt 2006 equinox LT.

I don't have check engine light on in dash. No error code too. but when I start the engine after 1 second both cooling fan Always on at high speed !

Do you have tips to me ?


The only thing I don't repair on equinox is A/C stuff refills.
Because when A/C refrigerant pressure sensor not work well it start both FAN but I don't have SENSOR error code

HELP ME PLEASE !

Thanks in advance !
nickthevoice is offline  
Old April 9th, 2008, 9:40 PM
  #2  
CF Junior Member
 
Join Date: Jan 2008
Location:
Posts: 71
Default RE: (2006 EQUINOX) 2 cooling fan ALWAYS ON !

it could possible be a radiator fan control relay
74chevy4life is offline  
Old March 12th, 2017, 9:29 PM
  #3  
New User
Awaiting E-mail Confirmation
 
Join Date: Mar 2017
Posts: 1
Default 2006 equinox

[QUOTE=nickthevoice;63532]Hello I rebuilt 2006 equinox LT.

I don't have check engine light on in dash. No error code too. but when I start the engine after 1 second both cooling fan Always on at high speed !

Do you have tips to me ?


The only thing I don't repair on equinox is A/C stuff refills.
Because when A/C refrigerant pressure sensor not work well it start both FAN but I don't have SENSOR error code

HELP ME PLEASE !

Thanks in advance

the same problem with my 2006 equinox both fans on..and my temperature is very low..pls help how to fix.. thank u
sandoyariel is offline  
Old January 27th, 2019, 2:10 PM
  #4  
CF Beginner
 
Join Date: Jan 2019
Posts: 1
Default

My low speed fan did not work at all. After reading through this thread I was thinking it was either a connector to the fan or the relay. Checking the relay was the easiest. With the car already warm but key off, I pulled the relay and following the mini schematic printed on its case, I completed the circuit with a small wire. Bingo! Low speed fan turned on, relay obviously not kicking in. Thanks for all the clues

Last edited by S. Sawyer; January 27th, 2019 at 2:21 PM.
S. Sawyer is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
missy
Equinox
34
October 1st, 2018 10:47 PM
Samanthageorge27
Cruze
6
October 27th, 2015 8:48 AM
ToolmakerMatt
Uplander
6
May 29th, 2015 6:12 PM
smanmail
General Tech
6
June 29th, 2014 3:21 PM
damone
Silverado & Fullsize Pick-ups
6
January 4th, 2012 7:14 PM


Thread Tools
Search this Thread
Quick Reply: (2006 EQUINOX) 2 cooling fan ALWAYS ON !


Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: