XM Radio Problem - Chevrolet Forum - Chevy Enthusiasts Forums

XM Radio Problem


jybarra's Avatar
CF Beginner

Join Date: Mar 2011
Posts: 1
Texas

March 6th, 2011, 12:25 PM   #1  
XM Radio Problem

2008 Silverado LTZ 1500, Z71, 2wd, 5.3l. I recently replaced the battery on the truck and my XM Radio quit working. I am an XM radio subscriber. XM has sent multiple reactivation signals to my radio, but it does not work. All other features of the radio are working. I have the factory Bose 6 CD radio with XM installed in the truck (no NAV). What could be wrong? I checked the antenna on the roof of the cab and does not appear to be loose or broken, but this only occurred when I replaced the truck battery.

Attached Thumbnails
XM Radio Problem-222010334104911875.jpg

Last edited by jybarra; March 6th, 2011 at 1:00 PM. Reason: New Picture
 
Chevrolet Customer Service's Avatar
Official GM Rep

Join Date: Mar 2010
Posts: 4,161
Global Headquarters in Detroit, MI

March 8th, 2011, 4:12 PM   #2  
Have you tried having the vehicle checked at your dealership? They would be able to pinpoint the issue for you and fix it for you if you would like. Or you could simply use the diagnosis as a starting point for fixing the vehicle yourself. I hope that helps you. If you do decide to go to the dealer could you keep me up to date on the proceedings? Thank you.

Jeff Morris, Chevrolet Customer Service

 
jim2074's Avatar
CF Beginner

Join Date: Jun 2012
Posts: 2

February 12th, 2013, 12:30 PM   #3  
XM band not showing on radio

I had the same problem. Had a dead battery. After recharging the battery no XM was showing on my radio. When I would push the band button only FM and AM would show.

Called dealer told me to pull both positive and negative battery cables off of battery. Then touch them together and hook back up.

That solved the problem. My XM band is now showing again. Hoooray!!!

 
mac76's Avatar
CF Beginner

Join Date: Apr 2014
Posts: 1

April 25th, 2014, 2:42 PM   #4  
I'll be damned, it worked! I went to 3 GM dealers and all said they didn't know what I was talking about. This is after XM told me I needed to go to a dealer and they would have to reset my XM band. One dealer wanted to charge me $90 to hook up to their computer and try to figure out how to reset my XM band.

After reading this suggestion, I tried it and it worked!!! Gotta love the internet.

 
Chevrolet Customer Service's Avatar
Official GM Rep

Join Date: Mar 2010
Posts: 4,161
Global Headquarters in Detroit, MI

April 25th, 2014, 3:03 PM   #5  
Hi mac76,

I am happy to hear the forum community has assisted with your concern! If you ever have any questions in the future, feel free to ask.

Jessica
Chevrolet Customer Care

Posted By: mac76 I'll be damned, it worked! I went to 3 GM dealers and all said they didn't know what I was talking about. This is after XM told me I needed to go to a dealer and they would have to reset my XM band. One dealer wanted to charge me $90 to hook up to their computer and try to figure out how to reset my XM band.

After reading this suggestion, I tried it and it worked!!! Gotta love the internet.

 
TxChevy75's Avatar
CF Beginner

Join Date: Jan 2015
Posts: 2
Texas

January 2nd, 2015, 2:30 PM   #6  
Posted By: jim2074 I had the same problem. Had a dead battery. After recharging the battery no XM was showing on my radio. When I would push the band button only FM and AM would show.

Called dealer told me to pull both positive and negative battery cables off of battery. Then touch them together and hook back up.

That solved the problem. My XM band is now showing again. Hoooray!!!
I have a Silverado LTZ Z71 and my battery went dead. Recharged it and I had the exact same issue. No XM whatsoever.

I tried this solution and IT WORKED! Thank you so much for posting this solution. It saved me a trip to the dealer.

 
jim2074's Avatar
CF Beginner

Join Date: Jun 2012
Posts: 2

January 3rd, 2015, 3:19 PM   #7  
So glad it worked out for you. Hard to believe that touching the two cables together would work. Saves time and hard earned money. Happy New Year

 
TxChevy75's Avatar
CF Beginner

Join Date: Jan 2015
Posts: 2
Texas

January 11th, 2015, 6:35 PM   #8  
I also want to add one other item that touching the two cables together corrected. I was also having a issue with my phone pairing through bluetooth. Before my battery went dead, I was able to use my phone through the hands free sound system. After the battery went dead and I recharged it, my phone would no longer connect.

I got into my truck the other day and I noticed "bluetooth" popped up on my display. It now magically works.

The dealer was telling me that I had to go through my OnStar system and contact them for a software update. I'm glad I didn't go that route.

Once again, thanks for the tip! It saved me a lot of time and potential service dollars.

 
hohenpa's Avatar
CF Beginner

Join Date: Jan 2015
Posts: 1

January 17th, 2015, 1:26 PM   #9  
I having the same issue with XM Radio. I'm gonna try this and see if it works for me.

 
Marc Breton's Avatar
CF Beginner

Join Date: Jul 2016
Posts: 1

July 5th, 2016, 9:48 PM   #10  
XM radio quits working.

Thanks for posting the solution to the XM radio problem,just tried it and it works. That's a life saver and so are you guys,will be back with my next problem on here. Keep up the good work!!!

 
Search this Thread
Sponsors
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: