Notices
Tahoe & Suburban The power, space, and brutal towing ability make the Tahoe and its longer sibling, the Suburban, arguably the best full size SUV's on the market today.

2013 Chevrolet Suburban
Platform: GMT 400, 800, 900

Oem Nav radio clock problem

Old February 23rd, 2019, 6:50 PM
  #11  
CF Senior Member
 
Join Date: Aug 2006
Posts: 507
Likes: 0
Received 0 Likes on 0 Posts
Default

So weird...my clock was only showing a colon as well after a battery disconnect maybe a month ago, then yesterday my wife said it was working again but not keeping the correct time...I will try this fix, but it doesnt say how to set time to UTC from GMT, what am i missing? do I just subtract the time diff. between the two, UTC and GMT?
Typerod is offline  
Old February 27th, 2019, 5:43 PM
  #12  
CF Beginner
 
Join Date: Feb 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Having same issue on my 11 avalanche ltz
Dan Perry is offline  
Old February 27th, 2019, 6:20 PM
  #13  
CF Beginner
 
Join Date: Feb 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Rhonda's post worked for me, thanks
Dan Perry is offline  
Old March 24th, 2019, 11:54 PM
  #14  
CF Beginner
 
Join Date: Mar 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Thumbs up My navigation clock didn't display. ...... Thank you for the fix

Originally Posted by Rhonda View Post
You need to do a hard reset of your clock. On the touchscreen, select the MENU button, when the screen changes, touch the lower left corner and hold until the PIN screen appears. Now enter the PIN code 295660, touch NEXT PAGE, then SET TIME. Here’s a video that shows how to do it:
https://m.youtube.com/watch?v=Btlu6CBeJQs#
Ms. Rhonda ...... Thank you for your post. I drive a GMC 2008 Hybrid Yukon. On Friday I was on a road trip ( three states away from my home Air Force Base) when my engine check light indicator came on. I stopped at the GMC dealership in the town that I was headed to. I asked them to tell me why my light came on. They said that I was throwing a P0521 code and to fix it I would have to have my Oil Pressure Sensor Switch and filter removed /replaced. After the repairs took place, I picked up my Yukon by COB (close of business) that day. (i.e. All of the mechanics were gone) When I drove off from there lot, I noticed that the clock was not being displayed. I did everything that I knew to do .... but nothing worked. I went back to the dealership on Saturday to ask them for help .... But of course they had know answers for the clock problem. And to top it off, while driving back to my place of orgin...... The ##[email protected]&&%*** engine check light indicator came back on. (Go Figure). It was'nt until I stumble on your post that I was able to get my clock back. Rhonda........ Thank you for looking out.
RespectfullyBro. Bruce
bro.bruce1 is offline  
Old April 30th, 2019, 12:15 PM
  #15  
CF Beginner
 
Join Date: Apr 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default My dam clock

Hats off to Rhonda got my dam clock back
Originally Posted by Rhonda View Post
You need to do a hard reset of your clock. On the touchscreen, select the MENU button, when the screen changes, touch the lower left corner and hold until the PIN screen appears. Now enter the PIN code 295660, touch NEXT PAGE, then SET TIME. Here’s a video that shows how to do it:
https://m.youtube.com/watch?v=Btlu6CBeJQs#
GMC beast is offline  
Old May 23rd, 2019, 4:50 PM
  #16  
CF Beginner
 
Join Date: May 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Works like a charm

Thanks so much, this worked and was so easy.

You need to do a hard reset of your clock. On the touchscreen, select the MENU button, when the screen changes, touch the lower left corner and hold until the PIN screen appears. Now enter the PIN code 295660, touch NEXT PAGE, then SET TIME. Here’s a video that shows how to do it:
https://m.youtube.com/watch?v=Btlu6CBeJQs#
[/QUOTE]
Lorie Page is offline  
Old June 13th, 2019, 3:35 PM
  #17  
CF Beginner
 
Join Date: Jun 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks worked! Got my clock back!!
Rob251 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
oniscus
Tahoe & Suburban
7
October 25th, 2011 8:23 PM
TyPierce
Tahoe & Suburban
0
August 8th, 2011 5:21 PM
bsoxbito
Silverado & Fullsize Pick-ups
1
October 5th, 2010 9:14 AM
basscat06
Tahoe & Suburban
5
March 14th, 2008 6:50 PM
basscat06
Tahoe & Suburban
0
February 26th, 2007 7:44 PM


Thread Tools
Search this Thread
Quick Reply: Oem Nav radio clock problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: