1994 S10 SS wont start?? - Chevrolet Forum - Chevy Enthusiasts Forums

1994 S10 SS wont start??


  Reply  
Join Date: Jan 2011
Posts: 2

January 5th, 2011, 11:06 AM   #1  
CF Beginner
1994 S10 SS wont start??

hello everyone,
i have a 1994 s10 ss with a 4.3 motor ive had this truck like 2 years now and had a new motor and transmission put in it a year ago. i never had any problems till now. the problem is i turn the truck on and when i drive away for like 10 minutes it automatically shuts off, when it does this ive checked to see if it still got fuel and still had spark and it did, ive also checked the fuel pressure. ive repalced coil, distributor, spark plug wires, spark plugs, ingnition module, and still had the problem. i was told maybe my computer was bad or a sensor but i have not that much time on my hands so im up for any advice that could help please!

 
Join Date: Dec 2010
Posts: 154
SC

January 7th, 2011, 10:56 PM   #2  
Super Moderator
Does it pop up any codes???

 
Join Date: Jan 2011
Posts: 10
Georgia

January 15th, 2011, 9:02 AM   #3  
CF Beginner
DJ Alacran,

We are going through the same situation you are, right now.. It sucks pretty bad. We are so ready to have this bad boy running. We have replaced so many parts thinking that was the issue. Have you figured out what was causing your truck to do what it was doing? We know we have a bad cam and 2 bad main bearings, we are hoping that when we replace them today, this will fix our little problem. I will let you know more by this afternoon. Hope to hear back from you soon. Thanks.

 
Join Date: Jan 2011
Posts: 2

May 24th, 2011, 12:05 PM   #4  
CF Beginner
ive checked for codes and no codes. could it be the fuel pump? ive replaced it 3 months ago. someone told me it could be a gas sensor? ive never heard of a gas sensor if there is where could it be? also where is the crank shaft sensor?
thanks!

 
Tags
Search this Thread
Sponsors
Related Topics