Go Back  Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Avalanche
Reload this Page >

engine power is reduced, service stabilitrak and service traction control

Notices
Avalanche Chevy's first real SUT, combining the interior room of an SUV and the cargo ability of a pickup truck.

Chevrolet Avalanche
Platform: GMT 805 & 900
Old July 29th, 2015, 1:08 PM
How-Tos on this Topic
Last edit by: IB Advertising
See related guides and technical advice from our community experts:

Browse all: Powertrain Guides
Print Wikipost

engine power is reduced, service stabilitrak and service traction control

Old November 7th, 2018, 8:12 AM
  #271  
CF Beginner
 
Join Date: Nov 2018
Posts: 1
Angry 2010 Equinox Service Stabillitrak / Engine Power Reduced

Last night out of the blue both errors came up on my equinox. "Service Stabillitrak / Engine Power Reduced" while not close to home and where there is no cell service. Drove 2 miles and it wouldnt go over 3000 RPMS or 50MPH and then it jsut shut off. Tried restarting and nothing, no click, no nothing, just lights. Let sit for 10 min and it fired back on but still had check engine light. Driving home as quiock as i can and mid drive the stabillitrak light and message comes on again. Got it home thankfully. I leave for a 14 hour drive to Nebraska on Friday and i am very concerned. Has this been fixed by GM and Covered at all? 167,000 miles on the vehicle, engine was replaced under recall/warranty at 100,006 miles by Chevy Dealrership. VIN - 2CNFLEEW4A6313214
ndvorak26 is offline  
Old November 12th, 2018, 10:44 AM
  #272  
CF Beginner
 
Join Date: Nov 2018
Posts: 5
Default Throttle Position Sensor

I had the warning display before and replacing the throttle position sensor fixed that issue. Hope this helps.

Originally Posted by Devil Dog View Post
I'm having the exact same problem with my 08 Avalanche LTZ. Service traction control, service stabilitrak, coming on then going away then coming back. All while the check engine light stays on steady. HELP!!!!!
Toilolo Toilolo is offline  
Old November 12th, 2018, 3:51 PM
  #273  
CF Beginner
 
Join Date: Nov 2018
Posts: 1
Default Same issue on my 2011 equinox now

We bought this equinox used 3 years ago and have put as much into it as we paid for it from the dealer. The dealer is Vic Canever Chevrolet. 3 months after buying a certified used we had to put $900 into it for a sensor. Then exactly 1 ywar after it the rear main seal blows and engine consumption with oil. That costed us another $2600. Every 3 months we have to put money into this thing. So much for certified pre owned. We jave always owned chevy or gm for the last 2t years but now rethinking because of this. Now its another $900 for throttle body and accelerator pedal sensor that is supposed to fix stabilitrak and engine power down.
Dan1976 is offline  
Old January 30th, 2019, 1:25 PM
  #274  
CF Beginner
 
Join Date: Jan 2019
Posts: 1
Default Same issue

[QUOTE=Chevrolet Customer Service;271422]Hey Rockhill and houston127,

I'm sorry to hear about this concern with your vehicles. I understand that you both have been in contact with your dealerships. Please feel free to follow up with us. I would like to create a case based on your concerns and also reach out to the dealership on your behalf. Please send us a private message or an email to [email protected] if any extra assistance is needed. Please include your VIN, current mileage, involved dealership, and full contact in the message. Thank you.

I have a 2010 GMC Acadia that is givingme the same 3 codes. I took it to the dealership they came up with "its the high pressure fuel pump" and the cost was going to be $1100, I had a bad feeling that they just came up with this issue instead of really testing the fuel pump so I went and picked up my car from the dealership yesterday and decided to do my own research. After researching I have found this post which tells me its either On Star or the throttle body. I called the dealershipback with this information and he says "oh well yeah it sounds like the throttle body" so I asked how they came up with it being the fuel pump and he says well thats what the technician came up with?!?!?!? Luckily I was smart enough to not pay the $1100 for the fuel pump and now I'm stuck with this issue after paying a diagnostic fee for them to guess what it was!! Now I'm afraid I'm going to have to pay another diagnostic fee to figure out if it was really OnStar or the throttle and hope that they actually find out facts instead of guessing just to take my money!


Stephanie Heath is offline  
Old February 1st, 2019, 9:35 PM
  #275  
CF Beginner
 
Join Date: Jul 2018
Posts: 2
Default

I also have the Stabilitrak/ Traction Control service messages frequently, mine is a 2007 Avalanche, 5.3. It seems to have a very common issue as I follow these postings. I read somewhere that GM may provide help with this, if under 120,000 miles. Can anyone confirm this, and who should I speak with? Need some good news, as I am disabled and don't want to be stranded somewhere. I will follow up as always, thank you!
Coldice88 is offline  
Old February 25th, 2019, 4:04 PM
  #276  
CF Beginner
 
Join Date: Jul 2018
Posts: 2
Default

An update on my Avalanche with the Stabilitrak/Traction control light coming on randomly (see above posts). My dealer service manager at Feldner Chevrolet in St. Cloud WI. personally analyzed the issue with his plug-in reader. While running we saw a pattern of frequent misses on cyl #1. After replacing the spark plug it cleared up everything. The center electrode had a build up of material that bridged to the other electrode, causing the short and misfire. I was very fortunate that was all it was. Thanks to my dealership as well as the GM rep online who coordinated the checkup.

I do wish that the messages were not so ambiguous as to cause "false" alerts. This had nothing to do with the Stabilitrak and it really shouldn't send that alarm. My advice, based on this one experience is to understand that can happen. Get the quick scan and you'll see where the problem actually is.
Coldice88 is offline  
Old March 7th, 2019, 1:01 PM
  #277  
CF Beginner
 
Join Date: Mar 2019
Posts: 1
Default

Good morning, I have a 2007 Avalanche at the dealer right now with this issue of the Stabilitrak/Traction control light coming on. The Chevy dealer just called and said they need to replace the entire engine! No smoke, No knock, Not 1 leak!! The truck went from running normal to needing an engine in an instant. Regular service records did not show any signs of this coming. Service writer says #4 cylinder is misfiring and has 5PSI compression.
mrjeffwilson is offline  
Old March 7th, 2019, 1:44 PM
  #278  
CF Junior Member
 
Join Date: Dec 2018
Location: Virginia
Posts: 68
Default

Originally Posted by mrjeffwilson View Post
Good morning, I have a 2007 Avalanche at the dealer right now with this issue of the Stabilitrak/Traction control light coming on. The Chevy dealer just called and said they need to replace the entire engine! No smoke, No knock, Not 1 leak!! The truck went from running normal to needing an engine in an instant. Regular service records did not show any signs of this coming. Service writer says #4 cylinder is misfiring and has 5PSI compression.
I think I get a 2nd opinion. Try another dealer or a reputable shop.
Doug D is offline  

Thread Tools
Search this Thread
Quick Reply: engine power is reduced, service stabilitrak and service traction control


Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: