P0178..Flex fuel sensor?? - Page 2 - Chevrolet Forum - Chevy Enthusiasts Forums

Tahoe & Suburban The power, space, and brutal towing ability make the Tahoe and its longer sibling, the Suburban, arguably the best full size SUV's on the market today.

2013 Chevrolet Suburban
Platform: GMT 400, 800, 900
Sponsored by:
Sponsored by:

P0178..Flex fuel sensor??

Reply

 
 
 
Old March 17th, 2015, 9:03 PM
  #11  
New User
Awaiting E-mail Confirmation
 
Join Date: Mar 2015
Posts: 1
Default help

Im having the same problem with my truck and it started a while back i thought it was the fuel pump ,should i try running it with flex fuel??? How can i find out if it runs with it or if it a non flex fuel I have a 2004 5.3 2wd vortec tahoe when i got it with 180,xxx miles i bought it from a dealership and it work fine gas saver too then out of nowhere i had fuel problems and started wasting gas i barely found out that 04 tahoe use flex fuel too...should i try it wirh flex fuel???? Were is the sensor located so i can clean it...i appreciate everybodys info God bless everybody
Jesus D,Angelo is offline  
Reply With Quote
Old March 20th, 2015, 12:08 PM
  #12  
Administrator
 
in2pro's Avatar
 
Join Date: Apr 2008
Location: Austin, Texas
Posts: 7,456
Default

Welcome to the forum...
I would NOT recommend running e-85 if you do not know if the engine is flex capable or not. You may need to have the alcohol reading reset if it is reading incorrectly...
in2pro is online now  
Reply With Quote
Old March 20th, 2015, 7:04 PM
  #13  
CF Monarch
 
tech2's Avatar
 
Join Date: Mar 2011
Posts: 6,236
Default

not sure what fault you are describing but if its running bad with regular fuel; using flex fuel won't make it better.
tech2 is offline  
Reply With Quote
Old October 31st, 2017, 10:19 AM
  #14  
CF Beginner
 
Join Date: Oct 2017
Location: New Jersey
Posts: 4
Default ever fix this

Originally Posted by Rvaburb View Post
My 04' burb has the same issue! I keep clearing out the code and tapping on the sensor with a mallet and it goes off for a hundred miles or so. Then the light comes back on and also reads the knock sensors are bad. I had not thought of really running flex fuel. Gas around here just contains 10% ethonal is that the same thing?
Hey Rvaburb, wondering if you ever fixed this issue with your 04 burb and flex fuel sensor? I've been having the same flex fuel sensor issue on my 05 1500 suburban Z71 for some time, I get a P0179 code and I tap on the flex sensor and it goes away for a while. Recently had the same sold start issue that you had, it started and was running rich, gave me codes P0172 & P0175, I tapped on the flex sensor and it all cleared up again. I figure the PCM was trying to compensate for a bad reading from the flex fuel sensor and caused the rich condition. Like most I hate to replace the $400 flex sensor if I don't need too. Thx in advance for any help.

Last edited by Mr_MarkG; October 31st, 2017 at 10:22 AM.
Mr_MarkG is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
adamanddiane
Tahoe & Suburban
1
September 25th, 2015 1:57 PM
ronboc
Tahoe & Suburban
24
January 29th, 2015 7:13 AM
bholaday
Impala
12
December 14th, 2014 8:43 PM
Exejx
Tahoe & Suburban
1
June 4th, 2011 9:46 PM


Thread Tools
Search this Thread
Quick Reply: P0178..Flex fuel sensor??


Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: