Notices
Tracker 1989-2004
This compact SUV proved itself to be a fine ecnomical vehicle, good for making its way along any type of surface.
Platform: CAMI (Suzuki)

Electrical issues 2004 Silverado Z71

Old April 25th, 2019, 11:07 AM
  #1  
CF Beginner
Thread Starter
 
Join Date: Apr 2019
Location: EDMONTON, AB
Posts: 2
Unhappy Electrical issues 2004 Silverado Z71

I have a 2004 Silverado Z71, 4WD, 5.3L, Extended Cab with electrical issues. It began with the radio time resetting to 12:00 am when i would start the truck and continues to this day. This later escalated to when turning the key the truck would start intermittently and when it didn't start there would be a clicking sound which was from the starter. Even later on when turning the key to the auxiliary position the dash lights might come on or just the check engine light and it would be dim and there would be no sound from starter when turning the key.
What i have done so far: Checked battery, Changed ignition switch, changed starter, cleaned ground wires on frame below drivers door, checked wires on throttle body (i did received a "low engine power") from dash display but only once during the last month or so since having the problem.( i changed the O2 sensors last year) I have read various posts on the same issue but with the changes i have had made it's still is not fixed. That said after changing the starter the truck will start after a couple of attempts (new starter still clicks on initial couple of try's). And once started it will start every time without clicking yet the clock will reset to 12:00 after every attempt.
Codes i have received: P0120, P0220, P1516 these came in January but i have not had these come up again. At my wits end! Any help would be appreciated.
Rgds ... Barry
Silverado2004 is offline  
Old May 15th, 2019, 11:13 AM
  #2  
CF Beginner
Thread Starter
 
Join Date: Apr 2019
Location: EDMONTON, AB
Posts: 2
Default

Issue resolved. Had the battery load tested and told it was fine but this was from the top posts only and not the side posts in other words how it is connected to the truck. The end result was the side post/s was faulty causing bad connection at times. Battery was a Sears model so won't be buying this brand again ... oh wait they are no longer in Canada so no worries

Wish i would have looked at that at the beginning myself. Oh well live and learn.
Silverado2004 is offline  

Thread Tools
Search this Thread
Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: